Imported CSV data does not display correctly in charts

Optuma Forums Optuma General Discussion Imported CSV data does not display correctly in charts

Tagged: 

  • This topic has 6 replies, 3 voices, and was last updated 1 year ago by Paul.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #54631
    Paul
    • Topics: 10
    • Replies: 8
    • Posts: 18

    Hi,

    I have a .csv file of the monthly Shiller CAPE Ratio data doing back to 1905.  I can import the file, but when I create the chart, it displays yearly instead of the monthly data.  Selecting a monthly time frame on the chart does not display the data correctly – it still defaults to yearly.  I have included the Excel csv file that I imported.

    Can Optuma read this monthly data and display it on a chart, or do I need to format the data differently?

    Thanks – Paul

    #54635
    Paul
    • Topics: 10
    • Replies: 8
    • Posts: 18

    One last questions – is there a limit to the historical data that can be imported into Optuma?  Thanks again – Paul

    #54641
    Matthew
    • Topics: 5
    • Replies: 625
    • Posts: 630

    Hi Paul,

    Looking at the CSV file the dates aren’t using the same format for all rows (Excel tends to remove extra zeros from dates when the file is first opened).  You need to adjust the date format to be the same across all rows to mm/dd/yyyy.

    Once that is done save the csv file and import / open it into Optuma.  When asked to setup the Text File Properties use the following:

    Ex1

    When i did this on my system the file imported correctly and i was able to display the chart using a 1 month time frame:

    Ex3

    For more information on how to format and import CSV files please refer to the following article: https://help.optuma.com/kb/faq.php?id=672

    With regards to your second query, there’s no limit on the amount of historical data you can import, however please note that dates before 01-01-1900 in Excel aren’t always picked up as valid dates, so formatting can be tricky.

    #54653
    Paul
    • Topics: 10
    • Replies: 8
    • Posts: 18

    As always thanks for your quick response and you help – Paul

    #65165
    • Topics: 13
    • Replies: 10
    • Posts: 23

    Hello sirs
    I have file  that I setting up with this article format
    https://help.optuma.com/kb/faq.php?id=672
    I don’t know why didn’t work

    #65172
    Matthew
    • Topics: 5
    • Replies: 625
    • Posts: 630

    Hi,

    There are several entries at the end of the CSV file which are missing a Date / Time value, that is why the CSV is not displaying correctly when imported into Optuma.

    Ex2

    You will need to delete these rows or fill in the missing Date / Time information.

    #65177
    • Topics: 13
    • Replies: 10
    • Posts: 23

    thank you Matthew

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

Pin It on Pinterest