RRG Weekly and Monthly TF's

Optuma Forums Optuma Scripting RRG Weekly and Monthly TF's

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #45123
    Steven
    • Topics: 8
    • Replies: 16
    • Posts: 24

    Hi,

     

    I’m wanting to display in an RRG Weekly scan, those GICS sectors that aren’t in quadrant 2 (Lagging) on the weekly and monthly timeframe.

     

    The weekly works fine but monthly JDKRS seems to have an issue – ideas?

     

    //RRG1=JDKRS(DEFAULT=Quadrant, INDEX=XJO:ASX).Quadrant<>2;

    RRG2=JDKRS(Month(PERIODAMOUNT=1), DEFAULT=Quadrant, INDEX=XJO:ASX).Quadrant<>2;

    //RRGInd = RRG1 and RRG2 and (ISTICKER()==XEJ or ISTICKER()==XIJ or ISTICKER()==XEJ or ISTICKER()==XUJ or ISTICKER()==XHJ or ISTICKER()==XPJ or ISTICKER()==XXJ or ISTICKER()==XMJ or ISTICKER()==XNJ or ISTICKER()==XSJ or ISTICKER()==XTJ);

    //RRGCheck = RRG1 and RRG2 and RRGInd;

    //RRGCheck = RRG1 and RRGInd;

    RRGCheck = RRG2;

    RRGCheck

     

     

    #45143
    Steven
    • Topics: 8
    • Replies: 16
    • Posts: 24

    Hi Darren

     

    I’m only doing GICS indices.

     

    Running this scan for XEJ produces zero results. I’d expect XEJ to appear – that’s the issue?

     

    Steve

     

     

    #45147
    Steven
    • Topics: 8
    • Replies: 16
    • Posts: 24

    See screen shot of results

    #45167
    Matthew
    • Topics: 5
    • Replies: 430
    • Posts: 435

    Hi Steven,

    Monthly data is dated with the 1st of the month.  The setting you have for a weekly scan doesn’t allow the data to go back far enough to include the monthly criteria (so nothing is passing).

    Change the Date Range to Last Fortnight or Last Month (anything that will include the 1st) and you will see the scan returns results.

    Ex7

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Pin It on Pinterest